深圳捷联讯通科技有限公司

 找回密码
 立即注册
查看: 8893|回复: 0

ROS 6.15 自动修改PCC脚本

[复制链接]

25

主题

53

帖子

575

积分

高级会员

小学生

Rank: 4

积分
575

热心会员活跃会员最佳新人

发表于 2014-7-16 09:38:41 | 显示全部楼层 |阅读模式





{
:local pppoeclientAllNum
:local pppoeclientRunNum
:local pppoeclientName
:local z 0
:set pppoeclientAllNum [:len [/interface pppoe-client find ]]
:log info ("pppoeclientAllNum".$pppoeclientAllNum)
:set pppoeclientRunNum [:len [/interface pppoe-client find running=yes]]
:log info ("pppoeclientRunNum".$pppoeclientRunNum)
:if ($pppoeclientRunNum < $pppoeclientAllNum) do={
  :for ii from=0 to=($pppoeclientAllNum-1) do={
   :log info $ii
   :if ($ii<=($pppoeclientRunNum-1)) do={
    /ip firewall mangle set [find per-connection-classifier~("/".$ii."\$")] per-connection-classifier=("both-addresses:".$pppoeclientRunNum."/".$ii) comment=("PCC" . $pppoeclientRunNum . "-" . $ii) disable=no
    /ip firewall mangle set [find action="mark-routing" connection-mark=[/ip firewall mangle get [find per-connection-classifier~("/".$ii."\$")] new-connection-mark ]] disable=no
    :log warning ("both-addresses:".$pppoeclientRunNum."/".$ii)
   } else={
    /ip firewall mangle set [find per-connection-classifier~("/".$ii."\$")] disable=yes
    /ip firewall mangle set [find action="mark-routing" connection-mark=[/ip firewall mangle get [find per-connection-classifier~("/".$ii."\$")] new-connection-mark ]] disable=yes
    :log warning ("both-addresses:".$pppoeclientAllNum."/".$ii."disable")
   }
  }
}
:if ($pppoeclientRunNum = $pppoeclientAllNum) do={
  :set z [:len [/ip firewall mangle find action="mark-connection" disabled=yes chain=prerouting]]
  :log info $z
  :if ($z>0) do={
   :for ii from=0 to=($pppoeclientRunNum-1) do={
    /ip firewall mangle set [find per-connection-classifier~("/".$ii."\$")] per-connection-classifier=("both-addresses:".$pppoeclientRunNum."/".$ii) comment=("PCC" . $pppoeclientRunNum . "-" . $ii) disable=no
    /ip firewall mangle set [find action="mark-routing" connection-mark=[/ip firewall mangle get [find per-connection-classifier~("/".$ii."\$")] new-connection-mark ]] disable=no
    :log warning ("both-addresses:".$pppoeclientRunNum."/".$ii)
   }
  }
}
}



好像不是链接 就是路由 要是数字,忘了 自己测试,这个脚本 现在 在6.15上用完全可以。

效果图

效果图
没有谁比谁厉害,只有谁比谁热心!
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|小黑屋|手机版|Archiver|EDCwifi.BBS ( 粤ICP备17065502号-1 粤公网安备44030702001530号 )

GMT+8, 2022-11-30 15:39 , Processed in 0.117868 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表